Мухи на стриме

Народ, помогите понять в чём проблема, бьюсь с ней уже очень давно. Вокруг мелких деталей всегда летают мухи, типа как на картинках, пережатых в jpeg Paint'ом. Вот видео для примера, здесь это хорошо видно с 2:50, мухи летают вокруг прицела и в правом нижнем углу, где открыт net_graph:

https://www.twitch.tv/exorcistv/v/89406992

 

Сейчас я стримлю через OBS, рестримлю через Nginx, почти один в один с настройками Фомби отсюда.

ffmpeg -re -i rtmp://localhost/live/original -vcodec libx264 -profile:v high -preset:v fast -r 60 -g 60 -keyint_min 60 -sc_threshold 0 -b:v 3500k -maxrate 3500k -bufsize 3500k -vf scale="-1:720,unsharp=luma_msize_x=3:luma_msize_y=3:luma_amount=1.03" -sws_flags lanczos+accurate_rnd+full_chroma_int -acodec copy -f flv rtmp://localhost/livetrans/original

Настройки OBS в приложенном выше видео у меня такие:
http://dl2.joxi.net/drive/2016/09/15/0001/2051/108547/47/b9663b02b7.png

http://dl2.joxi.net/drive/2016/09/15/0001/2051/108547/47/761506c72f.png

http://dl1.joxi.net/drive/2016/09/15/0001/2051/108547/47/cbba5d22c4.png

 

Интернет у меня довольно быстрый:

http://www.speedtest.net/my-result/5632208657

 

Комп тоже не сказать что слабый:

Проц: Intel Core i7-4790K.

Оперативка: 16Gb DDR3 (Kingston HyperX SAVAGE).

Видюха: MSI GeForce GTX 980 1216Mhz.

SSD: Kingston HyperX 240Gb.

 

Откуда эти мухи берутся - не понятно. Я уже перепробовал реально кучу вариаций настроек за последний год. Стримил и напрямую на Твич, без рестримов, пробовал выставлять разрешение экрана 720p, чтобы не уменьшать картинку - разницы нет. Единственное что более-менее исправляло ситуацию это когда я рестримил через Goodgame, а в OBS вырубал постоянный битрейт и ставил качество 10. Может кто-то сталкивался с подобной проблемой? Может у меня в настройках стоит что-то не так всё-таки? Может надо ещё провести какие-то тесты?